From f54fcdcd35d753524acbc80059bfa153ed2daa61 Mon Sep 17 00:00:00 2001 From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com> Date: Wed, 14 Oct 2026 21:18:42 +0000 Subject: [PATCH] Update flaml requirement from <2.6.0 to <2.8.0 in /mlos_core Updates the requirements on [flaml](https://github.com/microsoft/FLAML) to permit the latest version. - [Release notes](https://github.com/microsoft/FLAML/releases) - [Commits](https://github.com/microsoft/FLAML/compare/v0.1.0...v2.7.0) --- updated-dependencies: - dependency-name: flaml dependency-version: 2.7.0 dependency-type: direct:development ... Signed-off-by: dependabot[bot] --- mlos_core/setup.py | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/mlos_core/setup.py b/mlos_core/setup.py index adf5711b37..033c297e49 100644 --- a/mlos_core/setup.py +++ b/mlos_core/setup.py @@ -69,7 +69,7 @@ def _get_long_desc_from_readme(base_url: str) -> dict: extra_requires: dict[str, list[str]] = { # pylint: disable=consider-using-namedtuple-or-dataclass "flaml": [ - "flaml<2.6.0", + "flaml<2.8.0", "flaml[blendsearch]", ], # NOTE: Major refactoring on SMAC and ConfigSpace v1.0 starting from v2.2