Skip to content

Fix rustls advisory and consolidate dependency updates - #215

Merged
daisuke8000 merged 1 commit into
mainfrom
chore/security-dependency-refresh
Oct 12, 2026
Merged

daisuke8000 merged 1 commit into
mainfrom
chore/security-dependency-refresh

Conversation

@daisuke8000

Copy link
Copy Markdown
Owner

概要

Upgrade rustls to 0.23.45 and require that patched version in the workspace manifest, resolving RUSTSEC-2026-0285 for CLI and Kubernetes client TLS connections. Update anyhow and event-listener to their soundness fixes.

Consolidate the pending dependency updates and the SHA-pinned rust-toolchain action update. kube 4.2.0 requires Rust 1.89, so the workspace minimum, README, and both CI jobs now agree on that version. kube also uses the platform certificate verifier when kubeconfig omits a CA; a focused test builds that HTTPS client without connecting to a cluster.

変更理由

The existing rustls update to 0.23.43 does not fix the advisory, and the kube update cannot build on the previous Rust 1.88 minimum. This consolidates #198, #199, #200, #201, #202, #203, #205, #208, #209, #210, and #214.

Validation on Rust 1.89.0: format, locked workspace build, all-target clippy, core unit/integration/doc tests, and CLI binary unit tests passed. Latest cargo audit reports zero vulnerabilities and no unsound warnings; one unmaintained optional dependency warning remains for proc-macro-error2, which is absent from the active normal dependency tree.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant