You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
Repository navigation
Identify/decide minimum supported version of Rust #1276
If we go with 1.81+ we can use #[expect] with a lint reason, so I would prefer that in order to work towards adding clippy, but regardless of what version we use, we should probably add it to CI to ensure that we don't accidentally lose support
https://crates.io/crates/tokei -> requires 1.71+, documentation says "You can also build and install from source (requires the latest stable Rust compiler.)", they pin to ^0.19.0 so they just won't upgrade
I guess libgit2-sys can be a bit lower? That sys crate can be as low as 1.63.0 (pre sparse registry), thought I don't know if it is particularly useful.
We might also want to use the new ctest which requires 1.88 (#1262), though dev dependency doesn't really affect publish MSRV.
Activity
DanielEScherzer commentedon Jun 11, 2026
If we go with 1.81+ we can use
#[expect]with a lint reason, so I would prefer that in order to work towards adding clippy, but regardless of what version we use, we should probably add it to CI to ensure that we don't accidentally lose supportweihanglo commentedon Jun 11, 2026
Thanks for the analysis! Maybe we can run
https://crates.io/crates/cargo-msrvand figure out?DanielEScherzer commentedon Jun 11, 2026
Declare MSRV as 1.87, add tests for it
Declare MSRV as 1.87, add tests for it
Declare MSRV as 1.87, add tests for it
weihanglo commentedon Jun 11, 2026
Thanks for that. 1.87 sounds good to me. Do we want to check MSRV of our major consumers on crates.io / GitHub, and see if it may piss people off?
Declare MSRV as 1.87, add tests for it
weihanglo commentedon Jun 11, 2026
Also, I guess we probably need to set for also libgit2-sys?
Declare MSRV as 1.87, add tests for it
Declare MSRV as 1.87, add tests for it
DanielEScherzer commentedon Jun 11, 2026
Given that this doesn't compile with 1.86 I think major consumers would have already complained if they were trying to use older Rust
Checked all crates with over a million downloads (there are 1832 reverse dependencies, not going to check them all)
^0.20.0so they just won't update if needed^0so they just won't update if needed^0.14so they just won't update if needed^0.20so they just won't update if needed~0.21so they just won't update if needed>=0.21, <0.22so they just won't update^0.19.0so they just won't upgrade^0.20so they just won't update if neededweihanglo commentedon Jun 13, 2026
I guess
libgit2-syscan be a bit lower? That sys crate can be as low as 1.63.0 (pre sparse registry), thought I don't know if it is particularly useful.We might also want to use the new ctest which requires 1.88 (#1262), though dev dependency doesn't really affect publish MSRV.
I am fine with 1.87 for all. @ehuss any thought?
ehuss commentedon Jun 15, 2026
1.87 seems fine. I'm fine with an even newer version (like stable-3). Usually I just bump the rust version when there is some new feature I want/need.